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There are three main steps to Quality Control protocol for DTI 
1.) DICOM conversion – converting files to .nhdr files for use in programs 
2.) DTIPrep Automatic QC – Executing a protocol script to automatically QC scans 
3.) Visual DWI & DTI QC – Visual recheck of DITPrep QC results, preliminary fiber tracking, and 
visual check of signal loss and anomalies  
 

I. DICOM conversion 
 A. Run DicomConvert_HDNI.script on uncompressed file, adding the appropriate option for 

the protocol at the end of the command, for example, Phillips. 
 i. Two Dicom folders may be merged using DicomConv_HDNI_MergeTwo.script 

 B. Open DTIPrep GUI, click on “File” and then “Open DWI” to open the .nhdr file. 
 C. Record date of successful conversion on study's wiki page: 

http://pandora.ia.unc.edu/wiki/index.php/HDNI:General 
II. DTIPrep Automatic QC 

 A. Initial Visual QC  
 i. In DTIPrep, review baseline images in axial, sagittal, and coronal views. Note any 

issues of coverage, i.e. inferior axial slices missing such as the cerebellum and temporal 
lobe, and/or superior slices missing.  Second, notice any artifacts or motion in these 
scans, i.e. “venetian blind” effect, checks, etc.  DTIPrep will automatically detect and 
extract most of these artifacts.  For more details on these artifacts see section III - 
“Visual DWI & DTI QC” 

 
Figure 1.1 
“Bad coverage (severe)” a scan missing 
nearly all of the cerebellum and a large 
portion of the temporal lobe 
 
 
 
 

 B. Run Protocol 
 i. Click on the “Protocol” tab on the left side of the screen.  Select “Load” and choose the 

appropriate protocol script.  Click on RunByProtocol button on the bottom of the 
DTIPrep box. 

 ii. The results for each gradient check read Pass or Fail in the command line, depending on 
the parameters and threshold set in the protocol. [For this study the first two checks, the 
Image information check and Diffusion check, are inconsequential.  As well, the failure 
threshold is set at 30% for all scans except merged Phillips data from two scans, which 
is 60%] 

 
 
Figure 1.2 
Command line showing 
results overlaying 
DTIPrep GUI with 
protocol loaded 
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 iii. After the protocol runs, select 3D view tab and click on the sphere icon as well as the F 

and I icons to view distribution of directionality.  The F represents the directions before 
automatic QC.  These directions are represented in blue.  The I represents the directions 
left after the automatic QC, labeled in green. Note any major unevenness in spatial 
distribution.  [For the purposes of this study, “major unevenness in spatial distribution” 
is defined generously.  For example, no documentation of spatial gaps occurs unless a 
visual estimation equals approximately 40% or more of the sphere.] 
 
 

 
 
Figure 1.3 3D View displaying distribution of direction of gradients before and after automatic QC by 
DTIPrep 
 

 iv. As a reconfirmation of the Pass/Fail results from DTIPrep based on the set threshold 
percentage, view the QC Report and note the number of excluded gradients over the 
total number of directions in the dataset.  [Consider that the number of DWIs showing in 
the ~QCed.nhdr file may not add up to the original total minus the exclusions due to 
baseline averaging] 

 
III.  Visual DWI & DTI QC 

 A. Visual DWI QC 
 i. Open ~_QCed.nhdr file created by DTIPrep  
 ii. Selecting a representative slice, examine axial, sagittal and coronal views across all 

DWI gradients; adjust contrast and scroll through other slices as necessary.  
 iii. Document any perceived image quality issues; i.e. “venetian blind” effect (horizontal 

stripes), “checkers” effects - particularly in axial views, motion artifacts, gradients with 
intensity differences between slices and any other anomalies. 
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Figure 1.4 “Venetian Blind” Effect A clear example of the “venetian blind” artifact as seen in DTIPrep 
 

 iv. Run the extraction script, ExtractGradDir.py on the ~QCed.nhdr file, to remove 
directions deemed appropriate for manual exclusion based on image quality.  These 
include gradients with “venetian blind” effects (Fig. 1.4), “checkers” effects Fig. (1.5), 
motion artifacts as well as gradients containing one or more axial slices displaying 
higher or lower intensities across the whole slice (Fig. 1.7). 

 v. Record excluded directions on wiki page: 
http://pandora.ia.unc.edu/wiki/index.php/HDNI:General 

 
Figure 1.5 (left) “Checkers” artifact shown in an axial slice in 
a DWI gradient 
 
This artifact occurs most commonly in scans that also have a 
three-stripe blurring effect.  In this study, some of the 
Siemen’s protocol dataset contained these three-stripe blur 
artifacts as shown below in Fig. 1.6 
 
 

 
 

Figure 1.6 “Three-stripe blur” artifact 
in sagittal view of DWI gradients 
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Figure 1.7 DWI with a high-intensity axial slice as displayed in DTIPrep 
Although in the sagittal view this slice appears only halfway bright, both the axial and 
coronal views show a consistent difference in intensity compared to the surrounding slices 
 

 B. Preliminary DTI QC (glyphs and fiducial seeding) 
 i. Convert ~QCed_extracted.nhdr (or ~QCed.nhdr if there are no manual extractions) files 

into ~.nrrd files using CreateDTIImages.script and open ~float.nrrd file in Slicer under 
File>Add Volumes>Apply 

 ii. Glyph check 
 a) Under the “Volumes” module, select the “Display” drop down menu and change the 

Scalar Mode to “Color Orientation” 
 b) Select all three boxes in the “Glyphs Visibility Display” area  
 c) Adjust spacing setting as necessary to clearly see the individual glyphs 
 d) Look at the directionality of the glyphs in the Axial window, examine the Corpus 

Callosum, genu and splenium, to ensure that the glyphs are following the tract 
 e) Do the same with the coronal section of the CC, which can be seen in the Coronal 

slices.  After QC check, deselect the three glyph visibility boxes 
 
 
 
 
 
Figure 2.1 
 Selecting 
“Color 
Orientation” 
 in the Scalar 
Mode 
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Figure 2.2 Viewing Glyph Directions in Slicer – Selecting “glyph visibility” and changing the spacing 
 

 iii.  Tracking using Fiducial Seeding 
 a) Select the “Fiducials” Module and click on the arrow icon in the top icon toolbar, 

selecting “Use mouse to create-and-place persistently” to place seeds for five tracts: 
Corpus Callosum (genu, splenium, coronal); Cingulum, Uncinate, Arcuate, and 
Internal Capsule 

 b) Directionalities are demonstrated in the color map along the following orientations: 
red is left/right, green is anterior/posterior, and blue is inferior/superior 

 c) Seedmap labeling of tracts 
• CC – Starting in the Sagittal plane, identify the CC, which typically appears red 

in DTI Color Orientation maps.  It is bounded superiorly by the cingulum and 
inferiorly by the lateral ventricles.  Place a fiducial in the most anterior part to 
mark the genu.  Place another label in the posterior section of the CC, to mark 
the splenium.  In the coronal view, mark the CC at its vertex to track the coronal 
fiber bundles of the CC.   

• Cingulum – In the Coronal view, superior to the CC, is the cingulum appearing 
normally as two green “teardrop” shaped bodies.  Mark the left side cingulum. 

• Uncinate – In the axial view, move inferiorly through the slices.  Lateral to the 
brainstem, the anterior tip of the inferior longitudinal fasciculus appears 
blue/purple.  Place a fiducial on the right side to mark the uncinate. 

• Arcuate (2 fiducials) – In the axial view, locate the arcuate.  Lateral to the 
inferior fronto-occipital fasciculus/inferior longitudinal fasciculus, and at the 
temporo-parietal junction towards the posterior direction of the brain, lies a 
blue/purple portion of the arcuate.  Place a fiducial here.  “The fronto-parietal 
portion of the arcuate fasciculus encompasses a group of fibers with antero-
posterior direction (green)” that can be found lateral to the corticospinal tract a 
few axial slices superior from the last fiducial, place a second marker here. 
(Catani et. al., 2008, “A diffusion tensor imaging tractography atlas for virtual in 
vivo dissections”) 
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Figure 3.1 Placing Fiducial Label Seeds to track the Uncinate, Cingulum and Corpus Callosum (genu, 
splenium, and coronal section) 

 
 
 

• Place one fiducial in 
posterior portion 
(normally blue/purple) 
of the arcuate. (see left) 
Place another several 
slices up in the superior 
direction next to 
corticospinal tract, the 
arcuate is usually green 
here. (see right) 

 
 
 

• Internal Capsule – In the coronal view, medial to the arcuate and inferior 
longitudinal fasciculus and lateral to the CC is the internal capsule.  Usually, it is 
mostly blue/purple.  Place 2-3 fiducials in the internal capsule, particularly, in 
the most inferior part of the IC that is blue/purple 
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Figure 3.2 Placing Fiducial Label Seeds to track the Internal Capsule (IC) in Slicer 
 
 

 d) Diffusion Tractography for preliminary QC 
• Under “Modules”, go to Diffusion > Tractography> Fiducial Seeding; Choose 

“L” from the “Select FiducialList or Model” drop down menu, then “Create New 
Fiber Bundle” from the “Output Fiber Bundle Node” drop down menu.  

• Set the Stopping Value to 0.10, the Fiducial Seeding Region (mm) to 6.0 mm, 
and the Fiducial Seeding Step Size (mm) to 1.0 mm. 

 

Figure 3.3 Diffusion Tractography of Fiducial Labels 
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• [Optional] To increase speed and performance, it is possible to change the 
display of tubes to lines.  Go to Diffusion > Tractography > Fiber Bundles.  
Click on the “Lines” tab and select the “Visibility” box.  Click on the “Tubes” 
tab and deselect the “Visibility” box. 

Figure 3.4 Cingulum fiber bundle tractography viewed with Line display 
 

• Return to the Fiducials module, deselect any labels that are undesired to appear 
in the 3D Viewing pane.  Look to ensure that all tracts are present.  If they are 
incomplete, add more fiducial seeds in areas that are lacking.  Or, move the 
existing labels using the “Use mouse to Pick-and-Manipulate persistently” 
option under the hand icon.  If this is not successful, note any incomplete or 
missing tracts. 

Figure 3.5 Uncinate label only selected, shown with Sagittal slice in 3D window 



10 

 

 C. Visual QC for Signal Loss and Anomalies in the Scalar Diffusion Parameters 
 i. CreateDTIImages.script created the last of the separate scalar diffusion parameter files 
 ii. In ITK SNAP, open each scalar diffusion parameter ~.nrrd file – either reviewing them 

individually or using the “multisession cursor” option to scroll through the multiple 
images at once. Fractional Anisotrophy – FA; Mean Diffusivity – MD; Axial Diffusivity 
– AD; Radial Diffusivity – RD 

 

Figure 4.1 “Multisession Cursor and Crosshairs tool on AD and MD NRRD files” 
 

 a) Adjust the contrast as necessary in Tools>Image Contrast, manipulate the graph to 
change the darkness and brightness of the images 

 
 b) Visually check all slices for signal loss/noise represented by pixelated bright spots in 

the FA file and dark spots in the MD, AD, and RD files. 
 

• Look for clusters of this 
perceived signal loss.  If 
present, click the 
Crosshairs tool in the area 
and review the intensity 
information.  In the FA, 
anatomy should not equal 
more than 1.0.   

 
 
 
 

Figure 4.2 Adjusting Image Contrast in ITK SNAP 
 
In the MD, RD, and AD files, it should not be less than zero.  If these intensities are more than 
1.0 and less than 0, note the area for signal loss. 
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Figure 4.3 Signal Loss demonstrated in FA image in Right Pre-Frontal Lobe 
 

• Observe that some signal loss in the orbital regions is typical 
 

 
Figure 4.4 Diagonal NRRD artifact displayed in ITK SNAP, FA and MD images respectively 
This case was subsequently failed as a result of this issue with image-acquisition 

 
 c) During the visual check, also note any anomalous regions that may be due to 

anatomical lesions or problems in image acquisition.  In this study, four types of 
artifacts were identified in the scalar diffusion files: diagonal NRRD artifact, 
possible motion artifacts, wrapping artifacts and a pre-frontal anomaly traced to the 
Phillips protocol.   
 
• Diagonal NRRD artifact, Figure 4.4 demonstrates this diagonal striping artifact. 

The MD image reveals the large extent of the brain area affected by this issue. 
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Figure 4.5  
(left)  
Possible 
motion artifacts 
in the NRRD 
files 
 
 
Figure 4.6 
(right) 
Wrapping 
artifacts in the 
NRRD files 
 
 
 

 
• Possible motion artifacts such as the one displayed in Figure 4.5 are often 

apparent in inferior axial slices up through the eye area.  Like all visually 
detected artifacts, these are noted in the Visual QC notes on the wiki. 

• Wrapping artifacts contain one or several “shadow” images that may or may 
not be inverted.  In Figure 4.6, the eyes clearly mark this artifact. 

 

 
Figure 4.7 Pre-frontal anomaly in RD ~.nrrd file, axial and sagittal views 

 
• Figure 4.7 demonstrates a pre-frontal anomaly in ~50% of a dataset from a 

Phillips protocol. It is mostly visible in axial views, but is occasionally 
visible in the sagittal view as well. 

• If available, the color FA can be loaded on top of the FA ~.nrrd file in ITK 
SNAP for closer examination of such anomalies.  Go to File>Open RGB 
Image.  Click “Browse” to find the appropriate color FA ~.nrrd file 
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Figure 4.8 Pre-frontal anomaly in FA_color ~.nrrd file, 
Axial view in ITK SNAP 
 
 
This is the same case and anomaly as in Figure 4.7, but 
viewed in the FA color file.  The red arc showing in the 
pre-frontal area is not a result of anatomy and may be 
examined in Slicer for further evidence in determining 
whether the anomaly is anatomical or acquisition-
based.  
 
 
 
 
 
 
 

 
IV. Upload of Report to TrackHD 

 A. Login to the TrackHD website: https://www.track-hd.net/html/login 
 i.  Under the individual subject’s page, go to V3 and then click on the MRI  DTI QC bar 

to go to the QC page.   
 B. After selecting the appropriate Quality Control Result (pass, fail, or borderline), upload a 

PDF version of the ~QCReport.txt created by the DTIPrep QC protocol. 
 C.  In the Quality Control Comment box, record all QC notes that should already be on the 

wiki page, including coverage issues, percentage of gradients automatically excluded by 
DTIPrep, gradient numbers of manual exclusions, and Visual QC notes in the QC note field 
before submitting the report 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


